Database migration

This is a description of the eazyBI database migrator available from the Private eazyBI version 5.3.0.

The latest Private eazyBI version includes the database migrator functionality, which allows migrating the Private eazyBI database from one server to another and via file export/import.

eazyBI stores all data in a database. You can use the eazyBI database migration tool to move data from one server to another. See the data eazyBI will migrate in Select data for migration. It is also possible to choose some select eazyBI accounts to migrate the data to the new eazyBI database.

If you would like to migrate an existing eazyBI database to a new server, then first, set up a new eazyBI database and start Private eazyBI using this new database.

To access the eazyBI migration tool, click on the cog icon on the top right corner, and in the dropdown menu, select Database migrator.

On this page:


Migration types

From another database into this Private eazyBI

Connect the new Private eazyBI installation to an existing Private eazyBI database and pull the necessary data.

If you would like to migrate an existing Private eazyBI database to a new server and the new server can connect to the existing one then, start with a new Private eazyBI installation and set up a new Private eazyBI database.

After that, open the eazyBI database migrator in the new Private eazyBI installation and select the option to migrate data from another database into this server [1]. Then specify the database connection parameters to the existing Private eazyBI database [2] from which you would like to migrate the data.

Click Continue [3], and if there will be any problems with the database connection, then the errors will be displayed. If the connection to the database will be successful, then you will be forwarded to the Select data for migration page.

File export/import

Export eazyBI data from the existing Private eazyBI database and import the file in the new Private eazyBI installation.

If the server with the new Private eazyBI installation can not connect to the existing eazyBI database, but you still have physical access to the existing Private eazyBI installation, you can try to export all the information to a *.ZIP file.

First, open the eazyBI database migrator in the existing Private eazyBI installation and select the "From this server to export files" [1] migration type. Click Continue [2]. You will be forwarded to the Select data for migration page to select the eazyBI accounts to export into the file. Afterward, you can download the file.


After that, open the eazyBI database migrator in the new Private eazyBI installation and select the option to import data from the export file into this server [1]. Select the file [2] you exported from the existing server and click Continue [3]. If there are any problems with the file, then the errors will be displayed. You will be forwarded to the Select data for migration page to select the accounts you want to migrate into this server.


Select data for migration

The list of eazyBI accounts [1] will be displayed, which are available for import. If some of these accounts are disabled (greyed out) [2], then it means that either they are already imported, or there are existing accounts with the same name in the current eazyBI database.

Select all or some accounts that you would like to migrate and click the [3] Migrate button.

If you migrate an existing eazyBI database to a new empty database, then the Preserve original IDs option will be available and selected by defaultWith this option selected all existing account, report and dashboard ID values will be the same as in the original database. When you publish eazyBI reports or dashboards using iframes or as gadgets then these IDs are used as a reference.

The migration will copy the following data from the source database to the current database:

  • Accounts
  • Account users
  • Source application definitions (without imported data)
  • Source file definitions (without uploaded files)
  • Cube definitions (with no data)
  • Cube report definitions
  • Calculated member formulas
  • Dashboard definitions including email subscription settings

Re-import source data

Only source applications (like Jira, REST API, or SQL) definitions will be migrated. No source data are migrated. After the migration, go to the Source Data tab of each migrated account and verify the selected import options.

Finally, start the data import from all source applications. After the data import, you can go to the Analyze tab and open your existing reports.

If you had any uploaded source files, then please re-upload them in the Source Data tab and re-import data from all source files.