Data Import

Before you start to analyze data, you need to import that data into eazyBI. eazyBI is a non-real time analytical tool, which means that data are imported from the Source system into eazyBI database once or on regular basis and reports are built on data located in eazyBI database.

You may import data from Jira or other source systems using SQL SELECTREST API or from Excel files or Google Spreadhseets.

See the instruction video belove on how to import data from Jira.

 
 Video Transcript

After creating an eazyBI account you need to import data that you would like to analyze.

In the Source Data tab, you can either import data from standard source applications like Jira or import data from source files.

In this video, I will show you how to import Jira issues into eazyBI.

Let's add a new Jira source application. By default, Jira issues will be imported into the Issues cube. You can leave the default cube name and continue.

First, you need to select which Jira projects you would like to import. Only the projects which are visible to the current Jira user are shown.
Typically one or several related projects are imported into one eazyBI account.

If you have many small projects which are created frequently and you would always like to import all visible projects then click "Select all" and do not make any selection changes then eazyBI will select all visible projects when doing regularly scheduled imports.

In this case, we will select just a couple of projects for import. 

You can specify how frequently automatic regular data import will be performed.

By default, the next regular import will be performed up to 24 hours since the previous successful import.

You can specify that you would like to perform data import at a specified time. For example, early in the morning in the specified time zone. This is a typical selection as then you know that eazyBI reports are based on the snapshot of the data at the specified time.

When the first eazyBI data import is completed then the next import will be incremental.

Only the issues that were created or updated since that last import will be processed.

Therefore incremental import typically will be much faster than the full import.

But if you will change the import options then the next import will be full data import.

By default, all Jira issues from the selected projects will be imported.

If necessary you can specify additional JQL query to limit which issues will be imported.

For example, if you have a large Service Desk project and you do not want to import old closed issues then specify JQL query which will not select issues in the closed status if they were last updated more than a year ago.

In the next - statuses and history section you can specify which historical data you would like to import. 

Select import status transitions if you would like to analyze historical changes of statuses, assignees or sprints using transitions from status to status measures and the issues in transition status measure.

By default Jira stores an Issue resolution date when an issue was marked as resolved. This standard Jira resolution date field is used for issues resolved measure. But quite often after the resolved status, there are additional final closing or workflow statuses when the Issue resolution was accepted by the reporter or QA team.

In this case, you can select which statuses are these final closing statuses and you will get additional issues closed measure which can be used in reports.

If you would like to make burn-down charts using remaining estimated hours then select import remaining estimated hours history.

If you would like to analyze the age distribution of unresolved issues or resolution time distribution of resolved issues then select import age and resolution intervals.

You will be able to specify the distribution intervals when making a report in the analyze tab.

You can create reports by individual users using reporter assignee logged by and transition author dimensions.

As well as you can select which a user group dimensions you would like to import and use in your reports. 

By default, all user groups are created as user group dimension members. If you are interested just in a limited set of user groups then select only those groups from the list.

If you have installed Tempo timesheets or Zephyr Jira addons then you will be able to import additional measures from these add-ons.

Finally, you can show available custom fields in the selected Jira projects. You will see the list of custom fields which type is recognized by eazyBI.

If you do not see some custom field which you would like to import into eazyBI then see the documentation page about eazyBI custom field advanced options. Or ask eazyBI support for help. List of value type custom fields can be imported as additional issue cube dimensions. Numeric custom fields can be imported as measures and you will be able to analyze total some these numeric fields by other dimensions.

Also, date custom fields can be imported as measures. You can analyze the count of issues by the corresponding time period. Any custom field can be important as a property. You can use issue properties in the reports with the detailed issues on the rows. For numeric and data custom fields you can also import custom field value historical changes. Click "Import" to save import options and start Jira issues import into eazyBI.

Jira issues import is performed as a background job and you can see the current status of the import in the Source Data tab. If the import was successful then the next regular incremental import will be performed according to the specified regular import frequency. If you would like to start a manual import or if you would like to change any source selection options then click "Import" and you will see the same import Options page. 

Sometimes it might be necessary to re-import all Jira issues into eazyBI. If you see any issue data differences between Jira and eazyBI then probably the cause that Jira Index is out of date and eazyBI is not getting the correct data from the Jira index. In these cases, it is recommended to perform Jira re-index from the Jira administration page, go to eazyBI Analyze tab and empty issue cube. Then start Jira re-import from the Source Data tab. 

Now when you have your Jira data imported it's time to go to the Analyze tab and create some reports.