All eazyBI for Jira eazyBI for Confluence Private eazyBI

Data from Jira
eazyBI for Jira

Initial Import

After creating an eazyBI account, you need to import in the eazyBI database selected Jira project issues that you would like to analyze.

From the Source Data tab select Add new source application and then select the Jira application as a source application type.

The data import from Jira is authorized by the user who performs the initial data import: their Jira credentials are used to detect which projects and fields could be imported in this eazyBI account and are applied to all consecutive data imports (scheduled or manual). Inactive or non-existent users can't authorize data import: if the user access rights are changed in Jira (the user is deactivated or loses access to some of the selected projects), user authorization must be reset.

After that, the next screen Select application import options would be opened to continue the initial import setup.

 

Welcome to this tutorial on how to import data from Jira into eazyBI!

In the previous video, we provided an overview of the three main steps for getting started with eazyBI:  data import, report creation, and publishing.

In this video, let's take a look at the first step: how to import Jira data into eazyBI. During data import, Jira issues information is organized in a more report-friendly structure and prepared for report creation. You may find that someone has already imported the data. In which case, you can skip this video and go straight to the next one that covers how to create a report! 

Before we dig into imports, it is essential becoming familiar with the concept of eazyBI accounts. In eazyBI you can create one or several eazyBI accounts. In each eazyBI account, import a separate set of Jira projects and create a separate set of reports and dashboards that are needed for those projects. Pay attention that user access to eazyBI accounts should be defined separately from Jira security schemas! Give access to each eazyBI account to selected Jira users or user groups. Users will see only those accounts they were given access to. Dedicated eazyBI admins and Jira administrators are the most powerful roles in eazyBI. Then there are account-specific roles like report admin, user, and viewers. Read more about user access roles in the eazyBI documentation! 

In this video, we will cover the data import into one account. Let's start. Go to eazyBI and if you are the admin create a new account. If not, go to an account that has already been created and open the Source Data. Add a new data source and select Jira. If Jira is already added as a source, you won't be able to add it one more time. 

The General tab is the most important one. It is required that you choose what project data you want to import into this account. Select either by project name or project category. All other selections in the import process only define what kind of data from those projects will be imported. We will import Alpha, Beta, and Scrum projects. eazyBI recognizes what Jira products are used in the selected projects: Jira Core, Jira Software, or Jira Service Desk, and also suggest importing the relevant data for each one of them. Those can be Sprints, Story points or SLAs. If you do not plan to analyze this information, deselect it by clicking on each field name! Now, set up how frequently you want to update data from Jira into eazyBI. It is recommended to do a daily data import at a specified time that falls after working hours. Let's say 4 AM. Then let your team know that each morning, the fresh data will be available in eazyBI. Thankfully, scheduled data imports happen automatically, no one has to wake up for them! From here, if you only need the basic issue information, you are ready to click the Import button. 

But for this example, let's refine the data import a bit more. If you want to include data from other Jira apps, click the Add-ons tab and select what information you need. Only add-on apps available in your Jira as well as are integrated with eazyBI (2), appear in this tab. Please read more about this in the eazyBI documentation! We add Portfolio data.

In the Custom fields tab, you can select the custom fields you want to analyze. Choose how do you want to use them in your reports: dimensions, measures, and properties. Don't worry about choosing the wrong thing: only valid options are available for selection! So, it is OK to just click on the field name to add the field for the import. If some of the fields are missing or you want them to import differently, check out the eazyBI documentation about advanced settings for custom fields! In most cases, this is enough to complete the data import. Let's click the Import!

The first data import may take some time, but regular imports are incremental and, thus, much faster. Also, do not worry that someone can import data they do not have access to. Only issues and projects available in Jira for the person who authorized the data import or, in other words, has run the initial data import, will be imported into eazyBI. Whenever you need to make a change to the data import, open the screen in Edit mode, update the options and run the import again. Scheduled imports will automatically include the changes you made.

After the import is completed, in the Analyze tab you can see the data cube "Issues" is created. You can always know when the last regular data import was run and how fresh the imported data are! If they are stale and you do not have access to the Source Data tab, talk to your admin! Now everything is set up for the first report, all dimensions and measures are available.

Before wrapping this video episode up, one question: 

What kind of data is used to create reports in eazyBI?

  1. eazyBI connects directly to the Jira database, grab data as they are and build reports
  2. eazyBI imports data from Jira, organizes them in measures and dimensions and then you can create reports using them
  3. Jira standard information is imported into eazyBI, while data from custom fields and Jira apps are included directly from Jira

The correct answer is - eazyBI imports data from Jira, organizes them in measures and dimensions and then you can create reports using them

During this video, you learned how eazyBI data are organized into accounts and how to set up a data import from Jira to eazyBI. In the next video, we will talk about creating a meaningful report using imported measures and dimensions.


Select application import options

Select which Jira projects you would like to import in eazyBI. You can select all or individual projects and hide unselected ones, as well as clear selection [1], use the search filter to find your project [2], and even choose between projects and categories when selecting data for import [3]When a category for a project is changed in Jira, the project will be automatically deselected from eazyBI import if the new category isn't selected. 

During data import, eazyBI automatically imports data from Jira standard fields like Issue Type, Priority, Label, Fix version, Assignee, and a few others. Here is the list of all dimensions and measures. You don't need to select and import them separately. eazyBI provides additional import options for Software and Service Management project types.

Statuses and history

In the Statuses and history section select if you would like to import issue change history [1] as well as indicate Issues closed measure [2].

Option "Import issue change history" also should be selected if you want to import custom field changes (should be used together with option "Import value changes" for the custom fields and Sprints).

Regular import frequency

Specify how frequently you would like to schedule the regular Jira issues import. 

This will process created and modified issues since the last import:

In eazyBI for Jira Data Center and Server you can select "Every day", "Every hour", "Every 10 minutes" and similar options. The import will be processed 24h, 1 h or 10 minutes etc. after the last import (manual or regular). If you want to run the import every day at a particular time, select the "Daily at specified time" option.

In eazyBI for Jira Cloud the available import frequency is "Every day". You can select "Daily at specified time", to perform data import at a specific time of day. You can also import data manually at any time by clicking the "Import" button in the eazyBI "Source Data" tab. Enable Process events to import the most important events every hour.

If you have multiple eazyBI accounts, the sequence of pulling data in for them would be the same as the sequence these accounts had the last successfully completed import.

If the scheduled data import fails with an error, eazyBI automatically tries to reimport data 10 minutes after the failed import and repeats these attempts 9 more times. Note that import itself might take some time until it fails and eazyBI starts reimporting data 10 minutes later. After the 10th unsuccessful import attempt, a notification email would be sent to the eazyBI account's owner and the user who authorized data import from Jira. If eazyBI can not detect the owner or authorized import user, the notification will be sent to the technical contact registered for the eazyBI app license. 

Process events

Available only in eazyBI for Jira Cloud.

When Process events are selected eazyBI listens to the most essential Jira Cloud webhooks and updates data every hour even if the Regular import runs once a day.

Process events import data on:

  • Issue changes - creation, deletion, or updated (when the issue updated date is changed);
  • Worklog changes - creation, deleted, or updated;
  • Comment changes - created, deleted, or updated;
  • Issue link changes - added, deleted;
  • Sprint changes - deleted, updated, started and completed;
  • Sprint board configuration changes.

However, process events might not cover changes from Jira calculated fields and Jira apps (Tempo Planner, Xray, Zephyr Squad, etc) because these changes are not received with webhooks.

Initiate data import by pressing the "Import" button from the Source Data page or wait till the closest regular incremental import to get data from Jira apps.

JQL query filter

If you would like to analyze a subset of issues from selected projects, you can specify a JQL query that would limit which issues are imported.

  • To not import issues that have been closed for more than one year, you can use JQL status not in (Closed) OR updatedDate > -52w
  • To import issues that do not have any security level, use JQL level is empty
  • To limit by a saved Jira filter filter = "Name of saved Jira filter" (the filter must be available to the user who authorized the data import from Jira)


It is not allowed to use the "ORDER BY" clause of the JQL query in eazyBI. Implementation of data import is using its own ordering of issues.
eazyBI recognizes only functions from Jira advanced searching list; functions provided by other applications (like ScriptRunner) are not applicable in eazyBI import options.

Time dimension 

You can specify the time zone [1], the first day of the week [2] and non-working days [3] [4] of the Time dimension.

You can use only one time zone in each eazyBI account. The time zone of the Time dimension will be used to determine the date member in the Time dimension when importing issue measures (e.g. Issues created, Issues resolved and others) and issue properties. If a time zone is not specified then the default Jira server time zone will be used. If a different time zone will be selected then all date timestamps will be converted to this time zone.

The first day of the week  [2] is used for the Time dimension Weekly hierarchy and also Week Day dimension.

Non-working days (standard non-working days of the week and additional non-working days/holidays) will be used to calculate the new workdays measures – Average resolution workdays, Average age workdaysWorkdays in transition status, Average workdays in transition status. Non-working days of the Time dimension will be used also for DateDiffWorkdays and DateAddWorkdays MDX functions as a default non-working days argument.

If you have a long list of additional non-working days [4] then you can copy the list and paste in the time dimension options for the different eazyBI accounts.

It is possible to add members for date range [5] in the Time dimension (all hierarchies) to analyze reports not just by time periods where eazyBI finds activity in the project issues but also by future periods which can be useful for forecast and trend analysis. See more on benefits of adding members for a date range.

Additional dimensions for user groups, intervals, and issue link fields

 You can import user groups for Assignee, Reporter, Logged by, or Transition author and specify set of groups you would like to use in your reports [1]. Select the option to import  Age and Resolution Intervals dimensions [2] if you would like to create reports by unresolved issue age intervals or by Issue resolution intervals.

If you use issue hierarchy in the reports and would like to see issue data at one hierarchy level but filter by another hierarchy level, you might want to import issue link field dimensions [3]. For example, get all data by Fix version of the related Epic.

Sample reports

Select the option "Import sample reports" to get a set of reports created by eazyBI and have a first look at your data in eazyBI. Learn more about Sample reports and how they are built.  

Template account

Select Template account [1] to import reports, dashboards, and calculated measures defined in a common template account. You can override [2] existing reports, dashboards, and calculated measures with reports, dashboards, and calculated measures from the template account. 

Jira Custom Fields

If you would like to import Jira custom fields then go to tab Custom fields [2] [3] or tab Add-ons [1] to import custom fields specific to Jira apps eazyBI has integration with [1]. And select custom fields you would like to import. And select either individual checkboxes (Import as a dimension, Import as a measure, Import as a property, or Import value changes) or click on a custom field name to select all available checkboxes for this custom field. Available import options depend on the custom field type or advanced settings for the custom field (if applied).

  • Select Import as dimension if you want to analyze total numbers by the custom field values (usually, these custom fields are used to classify issues by some parameter). 
  • If the custom field is specific for each issue and you just want to get this information when looking on a particular issue, import it as property. 
  • If you want to get totals of numeric or date fields import them as measures. In the result, a set of measures with totals of custom field numeric values or measures with custom date fields would be created.
  • If you want to see how numeric custom field values are changed over time, then import value changes.

Custom fields from team-managed projects are grouped in Custom fields (Nex-gen). Each custom field has its name as you have it in Jira and the project key in the parenthesis to distinguish them and see which fields work with which project data.

Please select only those custom fields which you need for analysis purposes. Too many imported custom fields might slow down eazyBI reports.

Data import and import status

After specifying import options click Import to start Jira issues import background job.

In the Source Data tab, you will see the current status of the Jira import background job, as well as additional information - when the data cube was created, projects imported in this cube, imported projects, and a user whose credentials are used to authorize Jira for data import.

If you have many Jira issues and have selected many custom fields for import then the initial import might take a longer time to complete. In the Status column, you will see how many issues have been imported so far to estimate completion time.

Some data problems might not stop the import, but they will display in the warning message for the import status. The warnings remain visible to the user until dismissed manually. If you see such a warning, check if you can fix the data, dismiss the warning and rerun the import to have all your data imported.

Incremental import

After each successful Jira issues import, eazyBI will store a timestamp for processed Jira issues.

During regular Jira data import (either manual or automatic), eazyBI will import only those Jira issues which have been created, updated, or deleted since the last import. Incremental Jira data imports are much faster than the initial import.

If you change import options (for example, add an additional project or select additional custom fields), eazyBI will force a full re-import of all Jira issues.

Edit import options

Whenever needed, you can change the import options – select other projects or custom fields, change import frequency or enable/disable options. For that, go to Source Data tab and click Edit to open import options screen.

When import options are modified, click Import to start manual data import with applied changes or click Save to save them for later (the new options would be applied during the next regular import).

If you unselect projects from data import into the account, then it is advised to perform full data re-import. Otherwise, dimension members related to the previously imported projects are still available: while they have neither any related issues nor measures, their availability could be confusing for customers.

Re-import all data

In some cases, you may want to reimport just data (measures). During this import, Issues are not being deleted and reports will not appear empty until the import is completed.

This import would not delete dimension members but would add newly created dimension members. This can be useful when a numeric field is changed in Jira.

To re-import all data, go to Source Data tab and click Re-import all data.

If you have older eazyBI version than 5.0.0, then the only way to reimport all data is by emptying the whole cube and re-importing all issues. Please follow the next section to find out more about that!

Empty cube and re-import all issues

Sometimes you would need to recreate all dimension members (for example, new custom field value in Jira is created and used for issues). During this import, reports may seem empty as it reimports all issues (and other dimension members) from the beginning.


To re-import all issues, go to Analyze tab and click Empty button for Issues cube (it will delete just imported data but all created reports and calculated members will remain).

And then return to Source Data tab and click Import to start new re-import of all data.

If Jira configuration is changed then it is recommended to perform Jira re-index as otherwise Jira search API (which is used by eazyBI Jira import) might return incomplete results and as a result not all selected Jira issues will be imported in eazyBI. If there is a problem that not all Jira issues are visible in eazyBI then please perform Jira re-index and then do Jira re-import in eazyBI.


Reset authorization

When the user who had initially authorized Jira for data import is not available anymore (is inactive) or does not have permissions to the needed project, data source authorization should be reset to another user, otherwise, the next data import won't be successful (will end with error).

The new user has to be added to the account with Owner, User Admin, or Data Admin account user roles. She should log in eazyBI, open Source tab and click Reset authorization.

After approving this action, the Status will be changed to "Authorized" and a username of the new user will be visible under Source selection. 

Open Edit import settings to select projects and custom fields available for the new user and perform data import.

After reset authorization, the user should run the first import manually. After the first manual import imports will run as scheduled automatically with the new user credentials.

If you import data from Jira apps that require an API key to access data, you might want to generate a new key for the new authorized user.

Export Jira source application definition

With the Jira source application definition export, you can share the Jira import options from one account across one or several others. We recommend using this option within the same eazyBI instance to ensure the same set of available projects, integrations, and custom field names. Typical use-cases are when you would like to copy the settings of one account and use them on a different set of projects or create a sandbox account to try out new solutions.  However, if you would like to use one account as a template for many other accounts, you might want to use another option and create a Template account.

To export the definition of Jira source application, open the Source data tab, and click Export definition. Copy the definition.

To import the definition, create a new eazyBI account or open an existing one without a Jira source application. In this account, add a new source application and click on Import definition. Paste the definition and click Create.

After that, you will be forwarded to the Import options of the Jira source application. Please verify them and click on Import.

Rename data cube

When you add Jira as a data source and import data, eazyBI creates a data cube with the default name "Issues". However, you may rename the cube from Analyze tab.