Database migration

The eazyBI database migration is available starting from the eazyBI version 4.0.0.

eazyBI stores all data in a separate database. You can use the eazyBI database migration to migrate either all eazyBI data from one server to another or you can use it to migrate just couple eazyBI accounts from, for example, a production server to a test server.

If you would like to migrate existing eazyBI database to a new server then, at first, start a new eazyBI installation and set up a new eazyBI database. After that, go to eazyBI Administration / Settings and in the top navigation click System Administration and then from System administration tasks select Database migrator.

 


On this page:

Source eazyBI database

In the first step specify the database connection parameters to the existing eazyBI database from which you would like to migrate data.

Click Continue and if there will be any problems with the database connection then the errors will be displayed. If the database connection will be successful then the next page will be shown.

Select data for migration

The list of eazyBI accounts will be displayed which are available for import. If some of these accounts are disabled then it means that either they are already imported or there are existing accounts with the same name in the current eazyBI database.

Starting from the version 4.2.3 you can select the option Preserve original IDs. This option is recommended (and selected by default) when migrating an existing eazyBI database to a new empty database as then all existing account, report and dashboard ID values will be the same as in the original database. When you publish eazyBI report or dashboard gadgets on Jira dashboards or on Confluence pages then these IDs are stored as references. If you migrate the eazyBI database and preserve these IDs then all gadgets in Jira dashboards and Confluence pages will continue to work after the migration.

Select all or some accounts that you would like to migrate and click the Migrate button.

The migration will copy the following data from the source database to the current database:

  • Accounts
  • Account users
  • Source application definitions (without imported data)
  • Source file definitions (without uploaded files)
  • Cube definitions (with no data)
  • Cube report definitions
  • Calculated member formulas
  • Dashboard definitions

After successful import, you will be redirected to the home tab.

Re-import source data

Only source application (like Jira, REST API or SQL) definitions will be migrated but no source data are migrated. After the migration, you need to go to the Source Data tab in each account and start the data import from all source applications. After the data import, you can go to the Analyze tab and open your existing reports.

If you had any uploaded source files then please re-upload them in the Source Data tab and re-import data from all source files.

Gadgets in Jira dashboards and Confluence pages

When you publish eazyBI reports or dashboards as gadgets on Jira dashboards and Confluence pages then internal report or dashboard ID is saved in the gadget parameters. After database migration internal report and dashboard IDs might be different as in the source database. Therefore please verify all published eazyBI gadgets if they show the correct reports and dashboards and if necessary change gadget settings.