Training videos

Watch step by step training videos on how to get started with eazyBI: main concepts, data import, report creation, chart customization, and, finally, sharing reports. The training videos are based on data from Jira: there are a few differences in account creation and data imports, as well as some sharing options, are available only for Jira app. However, the eazyBI main concepts and options covered in the videos remain the same for all data sources and eazyBI products!

Even experienced users might find some overlooked features on how to use eazyBI with more ease. For beginners, we recommend watching them in the given order. Those videos are created in cooperation with Atlassian University

Additionally, we have gathered video recordings on different topics from our events that you can use for shaping your eazyBI skills. They are for different experience levels - beginners as well as eazyBI veterans.


Let's get started

Episode 1: Introduction to eazyBI (7:13 min)

Get to know what is eazyBI and understand the basic concepts of BI. Introduction in main eazyBI process steps: import data - create reports - share them!

In this episode:

  • What is eazyBI and how it differs from standard reporting?
  • Overview of each process step: import data - create reports - share 
  • Introduction of measures and dimensions
 
 Video Transcript

Hello and welcome everyone!

Today we will introduce you to eazyBI reports and charts for Jira. This is the first episode of the series on how to create eazyBI reports. During the video, you will get to know eazyBI and have a quick overview of its basic concepts. eazyBI is a powerful analytics and reporting app for Jira. With eazyBI you can build custom reports, charts, and dashboards from your Jira issues with just a few clicks.

Jira contains several built-in reports and filtering options, so you may be asking, "How is eazyBI different?" As the name indicates, eazyBI is business intelligence or "BI" tool. Using eazyBI's drag-n-drop report builder, you can explore, gather, and compare data in new ways and extract the information you need to quickly answer specific questions. For example, while Jira reports and JQL queries are helpful for gathering Jira issue data, they don't always solve the tricky questions like totals, averages, and other custom calculations. 

In this video, we will take a quick overview of the three main steps that enable teams to begin benefitting from the many business intelligence capabilities of eazyBI: importing data, create reports, and, finally, publish them. 

Let's look into each of these steps in more detail. eazyBI is a non-real time analysis tool, which means the data you want to analyze must first be imported from a source system like Jira. In addition, eazyBI can accept data from Jira apps, SQL databases, REST API and other data sources. Use them separately or combine them with the Jira issues information!

Data import ensures that Jira issues information is organized in a more report-friendly structure. Imported data are organized into the building blocks of eazyBI reports, called measures and dimensions, which makes it possible for even complex reports to be created quickly using the drag-and-drop report builder. Let's take a closer look at the measures and dimensions!

All numerical values in Jira are imported as Measures and can be things like original estimate values or created or resolved issue counts. As you may know, Jira issues have fields that contain data like issue type, assignee, resolution, etc. These data and the Jira issues themselves are imported into eazyBI as DimensionsWhile dimensions identify the information being analyzed, measures show the quantitative value of it. Being able to separately pull dimensions and measures, eazyBI allows you to analyze data that, within Jira, may not be related.This means you can answer questions such as, "How many hours have been logged for all stories within the last month?" 

Once the initial data import is completed, automatic updates between eazyBI and Jira can be scheduled, for example, once a day or every hour. Manual data updates are always available, too. Once the data are imported, they are ready to be used in report creation. In the eazyBI drag-and-drop report builder, all imported Dimensions and Measures appear automatically. They can be added, removed, and combined in the report builder to quickly build custom Jira reports or simply explore the data. At first, you will likely use only the pre-defined measures. As you get more comfortable with eazyBI, you can start creating your own custom calculations using the powerful MDX editor with syntax highlighting and auto-complete. Once you select all the measures and dimensions for the report, you then choose how to represent data: put them into a pivot table, a bar or a pie chart, or a combination of columns, ranges, and lines. 

The last, but not least phase is publishing reports, which makes it possible to share them with your team and stakeholders. There are several ways to do that. For instance, you could combine reports created in eazyBI into a dashboard that tells a story about a project's progress in a glance, which is perfect for sharing on a large screen in the office. Alternatively, use the eazyBI for Confluence app to share reports on a project's pages. 

Before we wrap up, let's do a quick knowledge check. 

What are the main eazyBI process steps?:

  1. Import data, Create reports, Publish reports.
  2. Correct data, Draw smooth lines, Print results.
  3. Identification, Specification, Representation

Import data, Create reports, Publish reports. - This is the correct answer.

What are measures and dimensions in eazyBI?

  1. Measures are kilometers, centimeters, millimeters, etc, Dimensions are height, depth, and width.
  2. Dimensions are alternative worlds, Measures are a number of worlds 
  3. Measures are a collection of quantitative metrics and Dimensions are lists of values

Correct! Measures are a collection of quantitative metrics and Dimensions are lists of values

In this video, we covered the basics of getting started: what is eazyBI, what are the main process steps, as well as the most important terms in eazyBI, measures, and dimensions. In the next episode, we will learn about eazyBI accounts and how to import Jira data into them. By the way, it's me, Roberts. Meet you in the next video!

See also:

Episode 2: Import data into eazyBI (7:57 min)

Overview of data import into eazyBI accounts and why importing matters. Learn more about the concept of eazyBI accounts!

In this episode:

  • Resume why data imports are necessary
  • What are eazyBI accounts
  • How to define basic import options
  • Importing data from Jira apps and custom fields
 
 Video Transcript

Welcome to this tutorial on how to import data from Jira into eazyBI!

In the previous video, we provided an overview of the three main steps for getting started with eazyBI:  data import, report creation, and publishing.

In this video, let's take a look at the first step: how to import Jira data into eazyBI. During data import, Jira issues information is organized in a more report-friendly structure and prepared for report creation. You may find that someone has already imported the data. In which case, you can skip this video and go straight to the next one that covers how to create a report! 

Before we dig into imports, it is essential becoming familiar with the concept of eazyBI accounts. In eazyBI you can create one or several eazyBI accounts. In each eazyBI account, import a separate set of Jira projects and create a separate set of reports and dashboards that are needed for those projects. Pay attention that user access to eazyBI accounts should be defined separately from Jira security schemas! Give access to each eazyBI account to selected Jira users or user groups. Users will see only those accounts they were given access to. Dedicated eazyBI admins and Jira administrators are the most powerful roles in eazyBI. Then there are account-specific roles like report admin, user, and viewers. Read more about user access roles in the eazyBI documentation! 

In this video, we will cover the data import into one account. Let's start. Go to eazyBI and if you are the admin create a new account. If not, go to an account that has already been created and open the Source Data. Add a new data source and select Jira. If Jira is already added as a source, you won't be able to add it one more time. 

The General tab is the most important one. It is required that you choose what project data you want to import into this account. Select either by project name or project category. All other selections in the import process only define what kind of data from those projects will be imported. We will import Alpha, Beta, and Scrum projects. eazyBI recognizes what Jira products are used in the selected projects: Jira Core, Jira Software, or Jira Service Desk, and also suggest importing the relevant data for each one of them. Those can be Sprints, Story points or SLAs. If you do not plan to analyze this information, deselect it by clicking on each field name! Now, set up how frequently you want to update data from Jira into eazyBI. It is recommended to do a daily data import at a specified time that falls after working hours. Let's say 4 AM. Then let your team know that each morning, the fresh data will be available in eazyBI. Thankfully, scheduled data imports happen automatically, no one has to wake up for them! From here, if you only need the basic issue information, you are ready to click the Import button. 

But for this example, let's refine the data import a bit more. If you want to include data from other Jira apps, click the Add-ons tab and select what information you need. Only add-on apps available in your Jira as well as are integrated with eazyBI (2), appear in this tab. Please read more about this in the eazyBI documentation! We add Portfolio data.

In the Custom fields tab, you can select the custom fields you want to analyze. Choose how do you want to use them in your reports: dimensions, measures, and properties. Don't worry about choosing the wrong thing: only valid options are available for selection! So, it is OK to just click on the field name to add the field for the import. If some of the fields are missing or you want them to import differently, check out the eazyBI documentation about advanced settings for custom fields! In most cases, this is enough to complete the data import. Let's click the Import!

The first data import may take some time, but regular imports are incremental and, thus, much faster. Also, do not worry that someone can import data they do not have access to. Only issues and projects available in Jira for the person who authorized the data import or, in other words, has run the initial data import, will be imported into eazyBI. Whenever you need to make a change to the data import, open the screen in Edit mode, update the options and run the import again. Scheduled imports will automatically include the changes you made.

After the import is completed, in the Analyze tab you can see the data cube "Issues" is created. You can always know when the last regular data import was run and how fresh the imported data are! If they are stale and you do not have access to the Source Data tab, talk to your admin! Now everything is set up for the first report, all dimensions and measures are available.

Before wrapping this video episode up, one question: 

What kind of data is used to create reports in eazyBI?

  1. eazyBI connects directly to the Jira database, grab data as they are and build reports
  2. eazyBI imports data from Jira, organizes them in measures and dimensions and then you can create reports using them
  3. Jira standard information is imported into eazyBI, while data from custom fields and Jira apps are included directly from Jira

The correct answer is - eazyBI imports data from Jira, organizes them in measures and dimensions and then you can create reports using them

During this video, you learned how eazyBI data are organized into accounts and how to set up a data import from Jira to eazyBI. In the next video, we will talk about creating a meaningful report using imported measures and dimensions.

See also:

Episode 3: Start building report (11:41 min)

Learn how to create a new report combining measures and dimensions and using different build-in options. Get familiar with the basic terms in eazyBI reporting.

In this episode

  • Measures are treasures, and dimensions are important, too.
  • Start with a table and notice report building areas: rows, columns, pages.
  • Understand the basic terms: dimension members, hierarchies, report context.
  • How to put the report together: drag-n-drop dimensions and pick measures, combine, expand, and bookmark members
  • Apply standard calculations to get trends, cumulative values, averages, etc.
  • Use BI options to explore data deeper: drill into, drill across and drill through issues options
 
 Video Transcript

Welcome to this tutorial on how to create a report in eazyBI for Jira!

In the last video, we got an overview of how to import data into eazyBI. In this video, we will dig into creating a report. Previously we learned that all Jira issue data are imported either as dimensions or as measures.

Report creation means combining both of them in a meaningful way. Reports are built on the Analyze tab. Before creating your own report, you may want to explore some sample reports as a way to see what's possible with eazyBI. 

When you're ready, click on the New report button. Before we get started, let's take a short tour of what is available in the report creation screen. All available dimensions are grouped in the Dimensions section. Measures are already moved to the report. Below the Dimensions area, the report builder contains Rows, Columns, and Pages. Anything moved to the Rows and Columns will be visible as headers of the report. If two or more dimensions are selected, all combinations of elements of them, called dimension members, would appear in the report. Dimensions added in the Pages will be used to filter the report data. For example, if we move the Project dimension into Pages and then select a single project, only issues from this project will be used in the report. All selected values in Rows, Columns, and Pages form what's called the report context.  This means each cell is calculated separately, taking into account what value is selected in the corresponding row, the column, and Pages.

We are now ready to start creating a report that will demonstrate the basic rules of report creation. In this example, we are creating a timeline that counts stories and bugs in a specific project, resolved in each particular month, as well as time spent on them. As an added bonus we would like the ability to see trends over time. We always suggest starting the report creation as a table even if you need a chart at the end. Don't worry, we will show how to represent table data as a chart in a later video! 

When creating a report, it's important to first understand what metrics need to be represented. These will determine the measures we select for the report. Are you interested in getting the number of issues? A count of transitions? The total logged hours? Once these are decided, we select them from the list of predefined measures. In our case, we need the number of resolved issues and how much time in hours was spentWe add the Time dimension to the report to organize measures according to when they were captured and to filter by a specific time period. After adding a dimension to the rows, the report table is created and the total number of resolved issues and spent hours is shown. 

Dimensions offer a built-in hierarchy, and at each level of the hierarchy, there are members that can be used to group measures in different ways. All dimensions contain an All level member, usually called the default member. It shows the aggregated value of all the members below. You can access all dimension members by expanding the default member. For the Time dimension, the hierarchy level members include years, quarters, months, and days. There is also a Weekly hierarchy with years, weeks, and days. Because the Time dimension has more than one hierarchical level, it may be necessary to expand the dimension panel and select the needed level directly. Let's select Months for our report. To limit the months by a specific year, add another instance of the Time dimension into Pages to set up a filter. As soon as a dimension is moved in Pages and value is selected, it limits what appears in the report rows. In our example, we select the year 2019, and we see the months of this year. Next, we add all other filter criteria to the report. We need to filter our report by a specific project or projects! There is an option to select several values from the same dimension as well, using the option "multiple", which would cause the report to retrieve issues from one or more projects. Only issues that match all the selected dimensions – or filter criteria – are included in the report. Sometimes it is useful to select the "All level" or default member when adding a dimension in Pages. This enables other report users to select their own filter criteria later. While the default member is selected, the filter does not affect the report data. 

Next, we need our values represented only for bugs and stories! For that, we need to add the Issue type dimension somewhere in the report. When a dimension is added together with a measure, the value is automatically calculated for each dimension member. While there are no hard rules about where a dimension be added, longer dimensions with more dimension members like Time and Issues are usually moved in the report Rows. You may want to narrow down visible dimension members. A quick way to select only one dimension member to be included in the report is to use the Select this option! If the result is not the one you desired, use the redo and undo options! The easiest way to add just a few select members is by using the Search and bookmark option. Then unselect the collapsed All level member and select the bookmarked ones. Voila! We have a report about resolved bugs and stories, and hours logged on them split by months.

Now we want to see a trend of how things went over time. Use the option Add calculated to draw a trend line for issues resolved; use the same option for hours spent to calculate the cumulative sum. You might want to explore other calculations that you can quickly add to your report! If the report gets too complicated, you can try to move the dimensions and measures around at any time. The result won't change. For instance, changing the sequence of dimensions in the Column section would change how data are grouped in the table - by measures or by issue types. Don't be afraid to experiment while creating the report! Notice, you can always see what is behind the total number: Click on the cell and select Drill through issues and open the list of them. You can even open them in Jira!  Drill across is another way how to explore this total by other dimensions. Let's see how resolved stories in May are split across priorities. Use the redo option to get back to the initial report! Depending on the report, it may be better displayed as a table or a chart. A timeline chart based on this table will be created In the next video. For now, remember to save the report to the Home folder or another specified location. Note that saving the report saves its structure, not the snapshot of data. When the report is opened, the values will automatically recalculate, based on the most recently imported information. Now the report is visible in the report list.

Before you go, let's take a short quiz:

What is mandatory to add to the report?

  1. Measures - False. While "Measure is a treasure", it is not enough to create a nice report based purely on measures. Something else is needed.
  2. Dimensions - False. Dimensions are a list of values and measures are not stored within them. 
  3. Both - True. Report creation means combining Measures or quantitative values with Dimensions or, in other words, numbers and the context of them.

It's pretty clear what Rows and Columns are on the report. What are Pages for?

  1. For adding new values - False. While changing the values in Pages affects numbers in the report, new values are not added. In opposite, values are filtered. Ooops, did the correct answer just slip out?
  2. For filtering - True. Dimensions added to Pages will be used as report filters.
  3. To enter a parallel world - False. I know, report creation sometimes seems a voodoo, but Pages are not a portal to a parallel world. Sorry.

In this video, we created our first report by combining dimensions and measures and adding some calculations. Go to the next video to see how to create a timeline chart based on this table report! 

See also:

Episode 4: Using charts (part I) (6:13 min)

Displaying report data in charts helps to perceive the message of the report on a glance. Start with a timeline chart and learn how to customize it! 

In this episode:

  • Start with a table report: charts are dynamically created!
  • Show the report data on a timeline chart and combine with different chart types
  • Adjust the chart to data: swap axis, change line type, change color, etc.
 
 Video Transcript

Welcome to this tutorial on how to create a chart using eazyBI! 

We have divided this topic into two videos. In this video, we will focus on the main customization options of charts and how to mix different types into one Timeline chart, while the second video explores other frequently used chart types and how to adjust them in order to get a useful final report. In the previous video, we learned how to build a report using eazyBI dimensions and measures. 

We created a table with the predefined measures Issues resolved and Hours spent and added calculations for trend line and cumulative values. In this tutorial, we'll save some time by reusing that report to create a chart, it just needs a little simplification by moving the Issue type dimension into Pages so we can concentrate more on the chart itself. Charts enable us to visualize the data and make it easier to identify trends at a glance. In eazyBI, there are different types of charts and each one of them suits different purposes. They can be combined or used in different ways that best meet the needs of the report users.

Let's start! Since we are using the Time dimension in our report, the Timeline chart is the best match for the data. Click the Timeline tab. When we switch to the Timeline chart we can see that this perhaps isn't the most compelling report ever created. With the current selections, all measures are represented as lines, which doesn't tell us much. However, with some adjustments, this view can change completely! The first thing we will do is changing the view from the lines to columns. Better already, but still, there is room for improvement.

As we have values with two different units in our report - the count of issues and the hours logged - it would be better to display measures in hours on a Separate axis. These simple changes have made this report much more useful but we can make it even more robust by combining different chart types in the same report. Let's use a dashed line for the resolved issues trendline and area for cumulative hours spent. 

We can also change the Color which resonates better with the nature of the selected measurements. As we have a count of issues resolved and hours spent as well as two additional measures using those units, we can simply use two colors in the chart to differentiate them.

We are almost there, but the area with Cumulative hours spent is taking a lot of attention. It would look better if this measure would be in the background, so we could see other measures too. Since measures in the chart are displayed in the same order as in the table, we switch to the table view and move this measure into the first column. Now we can switch back to the Timeline chart and it's looking great!

Last but not least - you can add a bit more detail for users to better perceive the information. Add names to the axis so we can easily understand which axis is for which measure. For clarity, a description also could be added to the report. Now we have completed the first chart! Don't forget to save it

Before we move on, there are a few more things on the timeline chart to explore: Like we did in the previous video when we built the report table, the same page filters are applied to the chart. Also, like with the table, we can drill into or across issues to see the issues behind those calculations in the chart. A cool feature specific to the Timeline chart is the ability to zoom in on the time period you are interested in reviewing.

Before we resume the video, let's do a quick quiz.

How data in the report chart are related to the data in the report table?

  1. The chart contains exactly the same information as the table and data in them are changed simultaneously. You can switch between the table and the chart at any time.
  2. Charts and tables are defined separately: once you have started changing something in the chart, data there are no longer comparable with the data in the table view.
  3. Tables are interactive, while charts are just cool pictures you can draw some additional information on.

The first answer is the correct one.

During this video, we learned how to display report data as a timeline chart and customize it. In the next video, let's get a quick overview of the other most frequently used charts.

See also:

  • See more about different chart types and options available.

Episode 5: Using charts (part II) (5:16 min)

Different data call for different charts. A quick overview of frequently used chart types.

In this episode:

  • Walkthrough the most popular chart types: bar chart, line chart, pie chart.
  • Some "good to know" things about each of the charts types.
 
 Video Transcript

Welcome to this overview of the types of charts available in eazyBI! 

In the previous video, we learned how to customize the Timeline chart in order to produce the final report. In addition to the Timeline chart, eazyBI has several other chart types to explore and we will do just that! 

From the Analyze tab, let's open the report that we created in an earlier video and modify it. To simplify the report, select only one measure: Issues resolved and change the grouping by the measure, not issue types. With this one report, we will be able to demonstrate most of the charts simply by switching between the tabs in the report builder. Let's have a look...

The bar chart is very popular. This chart can be used to compare different values from the same category. Use stacked bar charts to show a composition. Be careful about using too many composition items! Three to four are enough, otherwise, it can get messy very quickly! We will save a copy of this report using a different name so it can be easily found later. For stacked values, you can choose to display them either in absolute values or see a relative data comparison by selecting "Percentage"Data labels also can be added to see the values in the report. By the way, you can change the font size between small, medium and large! Alternatively, all this data can be displayed in a vertical bar chart simply by selecting Vertical in the options.

Line charts also are among the most frequently used chart types. Use lines when you have a continuous data set. These are best suited for trend-based visualizations of data over a period of time or iterations like sprints or releases. It is possible to change symbols for lines or to remove them entirely. 

An area chart is the same as a line chart with the area filled up below the line. Areas are typically stacked. The best use for this type of chart is for presenting cumulative value changes over time or iterations. Similar to the stacked bar chart, values on a stacked area chart can be displayed either in absolute values or as a relative data comparison by selecting Percentage.

A pie chart typically represents numbers in percentage and is used to visualize a part of a whole relationship or a composition. In this report, we are using the Time dimension and so the pie charts make more sense if the axes are swapped, making each pie to represent one month. Be careful not to bake too many pies as it would be hard to consume them all! 

A donut chart is essentially a Pie Chart except it has a round hole in the center which makes it look like a donut. For better visibility for this chart, we can switch to the Year level in the Time dimension, instead of the Month. Think of a donut chart as being a stacked bar graph that has been curled around on itself. 

We have several other charts too: Map chart, Gauge, Gantt and Scatter. We are going to explore them in later videos since they require a slightly specific report structure. Feel free to try them out by yourself, though!

Before you go, a short quiz that summarises the creation of reports and charts.

Which statement characterize the report creation in eazyBI most?:

  1. Open the Analyze tab and then go straight to the wanted chart type and start building the report there! The tables are old fashioned. 
  2. Be very careful: There is no way back! If you chose a chart type, then stick with it or start the report creation again.
  3. Create a table report, check data, and then switch to the needed chart type. You can change it at any time and, moreover, you can combine different chart types in one chart! 

The last answer is the correct one.

In this video, we have covered options of most typical chart types: line, bar, and pie charts. 

In the next video, we will learn how to share created reports and charts with other users using eazyBI dashboards as well as Jira dashboards!

See also:

  • See more about different chart types and options available.

Episode 6: Sharing reports (8:18 min)

A report gains added value when it is shared with customers or within the team. Learn how to combine reports in the eazyBI dashboard and share them in Jira (and in other ways, too).

In this episode:

  • Add reports to eazyBI dashboard to tell the whole story
  • Use common Page filter in the dashboard
  • Subscription to get the dashboard reports in the email
  • Use Jira gadgets to share eazyBI reports and dashboards
  • There are other ways how to share eazyBI reports, too!
 
 Video Transcript

Welcome to this tutorial on how to share eazyBI reports using dashboards!

In the previous videos, we learned how to import data and create reports in eazyBI. Sharing created reports is a crucial part of the whole report building process. To tell the story properly, you may want to use several reports that complement each other. Let's create a dashboard about issues resolution progress in time in our project. Dashboard creation starts in the Dashboard tab

Select any report from all your report folders and cubes if you have several. For our dashboard, we select the reports we created in previous videos: the timeline report with resolved issues trend and hours spent, and the bar chart with resolved issues by issue types. Use the search option!

Also, let's grab a sample report called Created vs resolved issues. It could provide a broader context in our dashboard. When reports are added, they might be expanded to see how large they tend to be. Then collapse them all again and reorganize their appearance in the dashboard by changing their size and position. Use percentage option and drag-n-drop reports. To improve visibility, we suggest adding charts with a similar size side by side. If possible, avoid using reports containing long lists in dashboards! 

As we use several reports about issue resolution, it is important that all of them would have the same context, for instance, they refer to the same time period, or project. To ensure that, take report Page filters outside as dashboard common Page filterSelecting a value from dashboard common Page filters, the filter will be applied to those dashboard reports that are having the same dimension in Pages.

Before saving the dashboard, a brief description can be added. It could help to interpret the information in the dashboard. Using Markdown formatting, the text can be styled and even a picture can be added. This is a great place to include your company logo! Give it a name and save the dashboard! Now eazyBI users who have access to eazyBI dashboards would see the reports you share!

When viewing the dashboard, it cannot be changed nor can the underlying reports. However, all other interactions with the report are still available: drilling through issues, or across values, changing Page selections, and switching between report chart and table views.

If you want to create a similar dashboard for another project, just replicate it: in the edit mode, copy the dashboard, change the Page selections, modify the description, save the dashboard with a different name, and voila! A dashboard for another project is created.

Now let's go one more step farther. How to share eazyBI dashboards? 

Anyone who can access dashboards can choose to subscribe to them, which will deliver the dashboard as a PDF to their email. This is great for automatically sending a fresh report before that weekly meeting! Of course, PDFs are not interactive, but they contain all the report information! 

The most frequently used way to share eazyBI reports and dashboards is a Jira dashboard. This probably isn’t surprising since it gathers the project’s key information into one place. Combined with other Jira standard charts, it is very convenient. eazyBI report and dashboard gadgets are added like any other Jira gadget. First, search for "eazyBI" and then select either one of them for publishing in Jira. Select the eazyBI account and then the dashboard itself.

By default, eazyBI reports published in Jira are also fully interactive. Though, you can limit interactions and allow only some of them. For example, you could enable only changing Page filters option while disabling all other actions. Now that we've added the eazyBI gadget to the Jira dashboard, the story about the project's progress is always visible whenever a user opens Jira! As a reminder, only users who have access to the given eazyBI account can see eazyBI report data published in the Jira dashboard!

There are other ways to share eazyBI dashboards: in other webpages using iframe, for non-Jira users, using public access token, in a Confluence page, using eazyBi for Confluence appor even on large screens using eazyBI Wallboard options. Check out eazyBI documentation and explore those options for sharing! 

Before we wrap up, one question for the knowledge check.

Where can you publish eazyBI reports and dashboards?

  1. Only in eazyBI
  2. In eazyBI and Jira dashboards
  3. In eazyBI, Jira dashboards, Confluence, external webpages, on monitors

While, during this video, we covered only report sharing in eazyBI and Jira dashboard, you can publish them also on Confluence, external webpage using iframe, or on large screens in Wallboard mode. Try all those options to benefit from eazyBI! 

Now you have learned: how to combine eazyBI reports in one eazyBI dashboard, how to share them to a wider audience using Jira dashboards, and there are more sharing options, too.

In the next video, get to know eazyBI Demo account pre-maid reports and learn how to transfer eazyBI reports and dashboards! 

See you in the last episode of the series! 

See also:

Episode 7: How to get reports fast from eazyBI Demo account (5:01 min)

There is a collection of ready-made eazyBI reports in the eazyBI Demo account: learn how to acquire them!

In this episode:

  • How to find eazyBI demo account and what could be found there
  • What is the report definition?
  • Export report or dashboard definitions and import them into your own eazyBI account
  • Adjust the imported reports to your data!
 
 Video Transcript

Welcome to this video tutorial where we will share how to add reports from the eazyBI demo account to your account!

In the previous episodes, we learned how to import data, create reports for use with different charts, and share them using dashboards. As mentioned in the previous videos, exploring the data in reports and experimenting with charts is a good way to become familiar with eazyBI.

To help with this, there is the eazyBI demo account where the eazyBI team have created samples of more than a hundred of the most popular reports: for project management or sprint analysis; different chart types; trendlines and tables. They can simply be an inspiration or they can be reused in your reporting! 

Let's start by finding the eazyBI demo account. The easiest approach is searching online for the phrase "eazyBI demo". You can also find links to the account from our documentation. In the eazyBI demo account, tabs Analyze and Dashboards are available in the header. No access permissions are required to explore and retrieve reports! The most popular reports are grouped in dashboards by themes - chart types, project or sprint overviews, etc. To practice on exporting and importing report definitions, let's find the dashboard called  Forecast and management dashboard and the report named Project prediction report. Select this report by clicking its title. To begin exporting the report, click the More menu and select Export definition. Don't worry about the data! In the report definition, only the structure of the report is included! Make sure all the text is highlighted and then click "Copy to clipboard". 

Next, navigate to our own eazyBI account.  Then, go to the Analyze tab and then Import reports. Paste the definition in the pop-up window and press OK. eazyBI displays a message about all new calculations used in this report, which will be created in this account during the definition import. Usually, there are no issues with importing, unless this eazyBI account already has calculated members with the same name. Then the calculation formula will be overwritten. Press Import if all is good. Open the imported report - it is ours now! 

Sometimes, the imported report in the account appears empty. This is because the Selected Page value is considered to be a part of the report structure and, thus, is included in the report definition. Since our eazyBI account does not contain the selected project from the Demo account, there is no data for it in the report. Let's filter the report by the project we have. Now we have a new report using our data in our account! In this case, remember to save the report with the new Page filter values

Did you notice that all the measures are there? Use them freely in your other reports, too!

Similarly, use the import and export options to import a whole demo dashboard to your eazyBI accounts. 

Now, a short quiz before leaving.

How to benefit from eazyBI the most?

  1. Learn eazyBI and create your own reports
  2. Explore and retrieve reports from Demo account
  3. Do both!

The correct answer is to do both, learn eazyBI and create your own reports, and also explore and retrieve reports from the Demo account! 

Now you have learned how to find the eazyBI Demo account and acquire new reports or dashboards fast just by copying them. Save time, don't reinvent the wheel!

We have completed the introduction series on how to use eazyBI. Thank you for keeping up with me during this first journey. See you soon!

See also: