All eazyBI for Jira eazyBI for Confluence Private eazyBI

Data from Jira
eazyBI for Jira

On this page:

Additional import options:

Initial Import

After creating an eazyBI account, you need to import into the eazyBI database the selected Jira project issues (or space work items in Jira Cloud) that you would like to analyze.

From the Source Data tab, select Add new source application and then select the Jira application as a source application type.

The data import from Jira is authorized by the user who performs the initial data import: their Jira credentials are used to detect which projects (or spaces in Jira Cloud) and fields could be imported into this eazyBI account and are applied to all consecutive data imports–scheduled or manual. Inactive or non-existent users can't authorize data import: if the user's access rights in Jira change (the user is deactivated or loses access to some of the selected projects), user authorization must be reset.

After that, the next screen, Select application import options, would be opened to continue the initial import setup.

 Video Transcript

Welcome to this tutorial on how to import data from Jira into eazyBI!

In the previous video, we provided an overview of the three main steps for getting started with eazyBI:  data import, report creation, and publishing.

In this video, let's take a look at the first step: how to import Jira data into eazyBI. During data import, Jira issues information is organized in a more report-friendly structure and prepared for report creation. You may find that someone has already imported the data. In which case, you can skip this video and go straight to the next one that covers how to create a report! 

Before we dig into imports, it is essential becoming familiar with the concept of eazyBI accounts. In eazyBI you can create one or several eazyBI accounts. In each eazyBI account, import a separate set of Jira projects and create a separate set of reports and dashboards that are needed for those projects. Pay attention that user access to eazyBI accounts should be defined separately from Jira security schemas! Give access to each eazyBI account to selected Jira users or user groups. Users will see only those accounts they were given access to. Dedicated eazyBI admins and Jira administrators are the most powerful roles in eazyBI. Then there are account-specific roles like report admin, user, and viewers. Read more about user access roles in the eazyBI documentation! 

In this video, we will cover the data import into one account. Let's start. Go to eazyBI and if you are the admin create a new account. If not, go to an account that has already been created and open the Source Data. Add a new data source and select Jira. If Jira is already added as a source, you won't be able to add it one more time. 

The General tab is the most important one. It is required that you choose what project data you want to import into this account. Select either by project name or project category. All other selections in the import process only define what kind of data from those projects will be imported. We will import Alpha, Beta, and Scrum projects. eazyBI recognizes what Jira products are used in the selected projects: Jira Core, Jira Software, or Jira Service Desk, and also suggest importing the relevant data for each one of them. Those can be Sprints, Story points or SLAs. If you do not plan to analyze this information, deselect it by clicking on each field name! Now, set up how frequently you want to update data from Jira into eazyBI. It is recommended to do a daily data import at a specified time that falls after working hours. Let's say 4 AM. Then let your team know that each morning, the fresh data will be available in eazyBI. Thankfully, scheduled data imports happen automatically, no one has to wake up for them! From here, if you only need the basic issue information, you are ready to click the Import button. 

But for this example, let's refine the data import a bit more. If you want to include data from other Jira apps, click the Add-ons tab and select what information you need. Only add-on apps available in your Jira as well as are integrated with eazyBI (2), appear in this tab. Please read more about this in the eazyBI documentation! We add Portfolio data.

In the Custom fields tab, you can select the custom fields you want to analyze. Choose how do you want to use them in your reports: dimensions, measures, and properties. Don't worry about choosing the wrong thing: only valid options are available for selection! So, it is OK to just click on the field name to add the field for the import. If some of the fields are missing or you want them to import differently, check out the eazyBI documentation about advanced settings for custom fields! In most cases, this is enough to complete the data import. Let's click the Import!

The first data import may take some time, but regular imports are incremental and, thus, much faster. Also, do not worry that someone can import data they do not have access to. Only issues and projects available in Jira for the person who authorized the data import or, in other words, has run the initial data import, will be imported into eazyBI. Whenever you need to make a change to the data import, open the screen in Edit mode, update the options and run the import again. Scheduled imports will automatically include the changes you made.

After the import is completed, in the Analyze tab you can see the data cube "Issues" is created. You can always know when the last regular data import was run and how fresh the imported data are! If they are stale and you do not have access to the Source Data tab, talk to your admin! Now everything is set up for the first report, all dimensions and measures are available.

Before wrapping this video episode up, one question: 

What kind of data is used to create reports in eazyBI?

  1. eazyBI connects directly to the Jira database, grab data as they are and build reports
  2. eazyBI imports data from Jira, organizes them in measures and dimensions and then you can create reports using them
  3. Jira standard information is imported into eazyBI, while data from custom fields and Jira apps are included directly from Jira

The correct answer is - eazyBI imports data from Jira, organizes them in measures and dimensions and then you can create reports using them

During this video, you learned how eazyBI data are organized into accounts and how to set up a data import from Jira to eazyBI. In the next video, we will talk about creating a meaningful report using imported measures and dimensions.

Select application import options

Select which Jira projects (or spaces in Jira Cloud) you would like to import into eazyBI. You can select all or individual projects, hide unselected ones, and clear the selection [1]. You can use the search filter to find your project [2] or choose between projects and categories when selecting data for import [3]. When a project category is changed in Jira, the project will be automatically deselected from the eazyBI import if the new category isn't selected. 

During data import, eazyBI automatically pulls data from Jira standard fields such as Issue Type, Priority, Label, Fix version, Assignee, and a few others. Here is the list of all dimensions and measures. You don't need to select and import them separately. eazyBI provides additional import options for Software and Service Management project types.

The option to keep archived project data is available on Cloud and eazyBI version 9.0.

You can preserve the data of archived projects in the eazyBI account if the project data was imported into this account before the project was archived [4]. For archived projects, eazyBI keeps previously imported data but does not update or recalculate it during data imports. The archived project list varies for each account based on previously selected projects:

Statuses and history

In the Statuses and history section, select if you would like to import issue change history [1] as well as indicate Issues closed measure [2].

Option "Import issue change history" should also be selected if you want to import custom field changes (use it together with the option "Import value changes" for custom fields and Sprints).

Regular import frequency

Specify how frequently you would like to schedule the regular Jira issues import. Scheduled imports are incremental; only the changes since the last import are imported.

In Cloud, the allowed import frequency for scheduling is once per day. Enable Data from Jira#Process events to import the most important events every hour.

Between scheduled imports, you can also import data manually at any time by clicking the Import button in the eazyBI Source Data tab. 

If you have multiple eazyBI accounts, the sequence for pulling data in for them would be the same as the sequence in which these accounts last successfully completed an import.

If the scheduled data import fails with an error, eazyBI automatically tries to reimport data 10 minutes after the failed import and repeats these attempts 9 more times. Note that import itself might take some time until it fails and eazyBI starts reimporting data 10 minutes later. After the 10th unsuccessful import attempt, a notification email would be sent to the eazyBI account's owner and the user who authorized data import from Jira. If eazyBI can not detect the owner or authorized import user, the notification will be sent to the technical contact registered for the eazyBI app license. 

Process events

Available only in eazyBI for Jira Cloud 

When Process events are selected, eazyBI listens to the most essential Jira Cloud webhooks and updates data every hour, even if the Regular import runs once a day.

Process events import data on:

However, process events might not capture changes from Jira calculated fields and Jira apps (Tempo Planner, Xray, Zephyr Squad, etc.) because these changes are not received via webhooks.

Initiate data import by pressing the "Import" button from the Source Data page, or wait till the closest regular incremental import to get data from Jira apps.

When making any changes in the import options page for the Jira source application, you must press the "Import" button to restart process events.

JQL query filter

If you would like to analyze a subset of issues from selected projects (or spaces in Jira Cloud), you can specify a JQL query that would limit which issues (or work items in Jira Cloud) are imported.

It is not allowed to use the "ORDER BY" clause of the JQL query in eazyBI. The data import implementation uses its own ordering of issues.
eazyBI recognizes only functions from the Jira advanced searching list. Enhanced search by Scriptrunner and functions provided by other applications are not applicable in eazyBI import options. In those cases, you should use saved Jira filter names in the eazyBI import options page.

We recommend limiting imported versions and components when using JQL filters to import only relevant components, fix versions, and affects version in the data cube. 

Time dimension 

You can specify the time zone [1], the first day of the week [2], and non-working days [3] [4] of the Time dimension.

You can use only one time zone in each eazyBI account. The Time dimension’s time zone will be used to determine the date member in the Time dimension when importing issue measures (e.g., Issues created, Issues resolved, and others) and issue properties. If a time zone is not specified then the default Jira server time zone will be used. If a different time zone is selected, all date and time stamps will be converted to this time zone.

The first day of the week  [2] is used for the Time dimension Weekly hierarchy and also the Week Day dimension.

Non-working days (standard non-working days of the week and additional non-working days/holidays) will be used to calculate the new workdays measures – Average resolution workdays, Average age workdays, Workdays in transition status, Average workdays in transition status. Non-working days of the Time dimension will also be used by the DateDiffWorkdays and DateAddWorkdays MDX functions as the default non-working days argument.

If you have a long list of additional non-working days [4], then you can copy the list and paste it into the time dimension options for the different eazyBI accounts.

It is possible to add members for date range [5] in the Time dimension (all hierarchies) to analyze reports not just by time periods where eazyBI finds activity in the project issues, but also by future periods, which can be useful for forecast and trend analysis. See more on benefits of adding members for a date range.

Additional dimensions for user groups, intervals, and issue link fields

You can import user project roles for Assignee and Reporter and user groups for Assignee, Reporter, Logged by, or Transition author and specify set of groups you would like to use in your reports [1].

Select the option to import  Age and Resolution Intervals dimensions [2] if you want to create reports by unresolved issue age intervals or Issue resolution intervals.

If you use issue hierarchy in the reports and would like to see issue data at one hierarchy level while filtering by another, you might want to import the issue link field dimensions [3]. For example, get all data by Fix version of the related Epic.

Additional measures for time tracking

If you would like a broader set of time-tracking measures, select the option to import additional measures for hours spent and original estimated hours.

Sample reports

Select the option "Import sample reports" to get a set of reports created by eazyBI and have a first look at your data in eazyBI. Learn more about Sample reports and how they are built.  

Template account

Select Template account [1] to import reports, dashboards, and calculated measures defined in a common template account. You can override [2] existing reports, dashboards, and calculated measures with reports, dashboards, and calculated measures from the template account. 

Jira Custom Fields

Select the custom fields you need in the Custom fields tab, including custom fields from company-managed and team-managed projects. To import custom fields specific to Jira apps, go to the Add-ons tab. Depending on the custom field type, you can import a custom field as a dimension, measure, or property, and import its value changes. For details on each custom field type and its import options, see the Jira custom fields page.

Global calculated fields in eazyBI appear in the custom field list among Jira custom fields. Account-specific calculated fields in eazyBI appear in a separate section, Calculated Custom fields, at the bottom of the page.

Import only the custom fields you need for analysis. Each additional custom field increases the import time.

eazyBI does not import issue links by default. In the Custom fields tab, use the Issue links section to specify which issue links to import: as a dimension of linked issues, or as an issue property with a comma-separated list of linked issue keys.

For details and examples, see the Import issue links page.

Data import and import status

After specifying import options, click Import to start the Jira issues import background job.

In the Source Data tab, you will see the current status of the Jira import background job, as well as additional information: when the data cube was created, projects (or spaces in Jira Cloud) imported into this cube, imported projects, and a user whose credentials are used to authorize Jira for data import. You can also download the log file for the last import for each source application (this option is available from More actions → Last import log).

Option to download the last import log available on the Cloud, since eazyBI version 9.0.

If you have many Jira issues and have selected many custom fields for import, the initial import might take longer to complete. In the Status column, you will see how many issues have been imported so far, which helps estimate completion time.

Some data problems might not stop the import, but they are displayed in the import status warning message and in the import log file. The warnings remain visible to the user until they are manually dismissed. If you see such a warning, check whether you can fix the data, dismiss the warning, and rerun the import to complete the import. 

Incremental import

After each successful Jira issues import, eazyBI will store a timestamp for processed Jira issues.

During a regular Jira data import (manual or automatic), eazyBI will import only Jira issues that have been created, updated, or deleted since the last import. All issues from archived projects, as well as archived issues, will automatically be removed from the "Issues" data cube. Incremental Jira data imports are much faster than the initial import.

If you change import options (for example, add an additional project or select additional custom fields), eazyBI will force a full re-import of all Jira issues.

The user can initiate the incremental import by manually pressing the Import button from the Source Data screen. By default, the Source Data page is available only to eazyBI account users with the data roles of Owner, User admin, and Data admin. But you can enable the option to start incremental import for the Report admin and User roles, too. This option cannot be combined with any data access roles. If the users can initiate incremental imports, they have unrestricted access to the data imported into the account.

The option to start an incremental import manually by the Report admin or User is available in eazyBI for Jira Cloud, starting with eazyBI version 8.2.

Edit import options

Whenever needed, you can change the import options – select other projects (or spaces in Jira Cloud) or custom fields, change import frequency, or enable/disable options. For that, go to Source Data tab and click Edit to open import options screen.

When import options are modified, click Import to start a manual data import with the applied changes, or click Save to save them for later (the new options will be applied during the next regular import).

If you unselect projects (or spaces in Jira Cloud) from data import into the account, then it is advised to perform full data re-import. Otherwise, dimension members related to the previously imported projects are still available; although they have neither related issues nor measures, their availability could be confusing for customers.

Delete members without data

You can delete members without data from dimensions in the Issues cube on Cloud, starting with eazyBI version 8.1.

You can delete members with no data from the Issues cube for the following dimensions:

It requires a data admin user role or higher to delete members without data.

Re-import all data

In some cases, you may want to reimport just the data (measures). During this import, Issues are not being deleted and reports will not appear empty until the import is completed.

This import would not delete dimension members but would add newly created dimension members. This can be useful when a numeric field is changed in Jira.

Go to the Source Data tab and click Re-import all data to re-import all data from Jira and its add-ons. Or you can Re-import add-on data if only add-on-specific data requires refreshing, like Align, /wiki/spaces/DEV/pages/1816298158, QMetry, Xray, Zephyr Scale (on Data Center only), and Zephyr Squad (on Data Center only).

Option to Re-import add-on data available on the Cloud and since eazyBI version 9.0.

Empty cube and re-import all issues

Sometimes you would need to recreate all dimension members based on the latest data. For example, a major renaming of select list values.  During this process, Empty and re-import reports may appear empty, as they re-import all issues and other dimension members from the beginning by deleting imported members first and then importing them.

To re-import all issues, go to the Analyze tab and click the Empty button for the Issues cube (it will delete just the imported data, but all created reports and calculated members will remain).

And then return to the Source Data tab and click Import to start a new re-import of all data.

See also the training video on other options for reimporting data: “Different Options to Reimport Data."”

If the Jira configuration is changed, then it is recommended to perform Jira re-index, as otherwise the Jira search API (which is used by eazyBI Jira import) might return incomplete results, and as a result, not all selected Jira issues will be imported into eazyBI. If there is a problem where not all Jira issues are visible in eazyBI, please perform a Jira re-index, then do a Jira re-import in eazyBI.

Do not perform Empty cube if you have archived project data in the account and do not want to lose it. Data from Archived projects are deleted but not restored after the Empty cube.

Reset authorization

When the user who initially authorized Jira for data import is no longer available (inactive) or does not have permissions on the required project, data source authorization should be reset to another user; otherwise, the next data import will fail (with an error).

The new user must be added to the account with the Owner, User Admin, or Data Admin user role. New users should log in to eazyBI, open the Source tab, and click Reset authorization. Users who have already allowed eazyBI to import data in this account won’t see the reset authorization option, since they’ve already authorized the import.

After approving this action, the Status will be changed to "Authorized," and the new user's username will be visible under Source selection. 

Open Edit import settings to select the projects and custom fields available to the new user, then perform the data import.

After reset authorization, the user should run the first import manually. After the first manual import, subsequent imports will run automatically with the new user credentials.

If you import data from Jira apps that require an API key, you might want to generate a new key for the authorized user.

Export source application definition

With the source application definition export, you can share the Jira and Assets import options from one account across one or several others. We recommend using this option within the same eazyBI instance to ensure the same set of available projects (or Spaces in Jira Cloud), integrations, and custom field names. Typical use cases include copying the settings of one account to use on a different set of projects or creating a sandbox account to try out new solutions.  However, if you would like to use one account as a template for multiple other accounts, consider using another option and create a Template account.

To export the definition of Jira and Assets source application, open the Source data tab, and click Export definition. Copy the definition.

To import the definition, create a new eazyBI account or open an existing one that does not have a Jira or Assets source application. In this account, add a new source application, then click Import definition. Paste the definition and click Create.

After that, you will be forwarded to the Import options of the Jira source application. Please verify them, then click Import.

The option to export and import the Assets source application is available since version 8.1. and on Cloud.

Rename data cube

When you add Jira as a data source and import data, eazyBI creates a data cube named "Issues" by default. However, you may rename the cube from Analyze tab.